Changes

19 bytes removed ,  19:27, 16 July 2018
no edit summary
Line 34: Line 34:     
* <code>pkg-config</code> to check on build library dependencies.
 
* <code>pkg-config</code> to check on build library dependencies.
* <code>python-ipaddress</code> is used by CRIT to pretty-print ip.
+
* <code>python-ipaddress</code> is used by CRIT to pretty-print IP addresses and is also required by zdtm.py
 
* <code>libbsd</code>. If available, CRIU will be compiled with <code>setproctitle()</code> support. It will allow to make process titles of service workers to be more verbose.
 
* <code>libbsd</code>. If available, CRIU will be compiled with <code>setproctitle()</code> support. It will allow to make process titles of service workers to be more verbose.
 
* <code>iproute2</code> version 3.5.0 or higher is needed for dumping network namespaces. The latest one can be cloned from [http://git.kernel.org/?p=linux/kernel/git/shemminger/iproute2.git;a=summary iproute2]. It should be compiled and a path to ip set as the [[environment variables|<code>CR_IP_TOOL</code> variable]]
 
* <code>iproute2</code> version 3.5.0 or higher is needed for dumping network namespaces. The latest one can be cloned from [http://git.kernel.org/?p=linux/kernel/git/shemminger/iproute2.git;a=summary iproute2]. It should be compiled and a path to ip set as the [[environment variables|<code>CR_IP_TOOL</code> variable]]
Line 41: Line 41:  
* <code>libaio-devel</code> (RPM) / <code>libaio-dev</code> (DEB) is needed to run tests
 
* <code>libaio-devel</code> (RPM) / <code>libaio-dev</code> (DEB) is needed to run tests
 
* <code>python2-future</code> or <code>python3-future</code> is now needed for zdtm.py tests launcher
 
* <code>python2-future</code> or <code>python3-future</code> is now needed for zdtm.py tests launcher
* <code>python-ipaddress</code> is also required by zdtm.py
      
For APT use the <code>--no-install-recommends</code> parameter is to avoid asciidoc pulling in a lot of dependencies.
 
For APT use the <code>--no-install-recommends</code> parameter is to avoid asciidoc pulling in a lot of dependencies.
74

edits